Parrot CK3100 Blank Screen (Display) and Bleeping

If you have a CK3100 and you are finding the display has gone blank (possibly still illuminating) and giving you ‘Bleeps’ when the ignition is switched on then there this is a sign of lost communication from the Blue junction box of the Parrot and the display, quite often this is caused by the display cable having a little ‘tug’ and slightly pulling apart a connector in the rear of the display. With a small flat screwdriver you can usually (Carefully) push the connector back together please see the picture below:

Ensure the White Connector is fully home.

This entry was posted in Parrot. Bookmark the permalink.

9 Responses to Parrot CK3100 Blank Screen (Display) and Bleeping

  1. Martin says:

    My parrot won’t connect Independently
    So I have to connect manually everytime the ignition is turned off!
    It also says after connecting memory full !! But there are no numbers or any other info stored on the unit!
    No paired phones .
    Can anyone help please?

  2. sue holland says:

    hi my parrot says goodbye on it and do’s not work now do i have to reset it thanks

    • Hi Sue, that’s a good question it’s very rare i hear of a CK3100 stuck on ‘Goodbye’ and if i do it’s usually when you turn off the ignition of the vehicle they do that (because the ignition supply wire is still holding 1 or 2 volts on it, it needs to go to zero volts) and when you put the ignition on again they work fine. It would be worth disconnecting the power to the Parrot kit for a few minutes and then plugging it back in and testing. Depending on the vehicle it may be easier to disconnect the vehicle battery for a couple of minutes which will obviously remove power from the Parrot too. (Make sure you have your stereo code if required)

  3. Mangala says:

    Hi I also have a problem in my parrot its displaying no signal? If anybody can help. Thanks

    • The same problem can cause this No Signal Issue too. The little plug in the back of the screen ‘makes & breaks’ whilst driving and seems to corrupt the CK3100. Check this connector is fully home, then ideally you need to unplug the Parrot Blue Junction Box for at least 5 minutes (worst case you could disconnect vehicle battery for 5 mins too – Caution of Radio Code etc) then reconnect the kit and see what happens. Sometimes this clears the fault other times the Parrot may need a Reflash of Software via a cable.

  4. Ray Parker says:

    Exactly what’s happening to mine
    Just tried what you said
    No luck with mine any other things I could try


    • Not really, if it still does it then you may have an actual break in the cable somewhere. It will be a new screen i’m afraid as the cable alone isn’t available from Parrot as a spare part unless you find someone selling one.

  5. hippo says:

    Thanks man, exactly my case. Probably my son should pull the cable…

Leave a Reply to sue holland Cancel reply

Your email address will not be published. Required fields are marked *